Questions tagged [ubuntu-18.04]

1

votes
2

answer
1.8k

Views

Snap Proxy doesn´t work

I try to install Conjure-Up on my Ubuntu 18.04 virtual machine with $sudo snap install conjure-up --classic But it always says: error: cannot install 'conjure-up': Post https://api.snapcraft.io/v2/snaps/refresh: proxyconnect tcp: EOF I have successfully set up my http and https proxy in /etc/environ...
Kai
0

votes
0

answer
12

Views

Rails/Ubuntu uninitialized namespaced constants on load

When starting my rails application on Ubuntu (through any process e.g. console, server, rake tasks, etc) I get an uninitialised constant error from my gems. However, I can clone the exact same repo on to OSX and it works. The error I show is coming from apartment, but if I remove the references to C...
matt_atoz
0

votes
0

answer
16

Views

Cannot find package “golang.org/x/net/context” in any of:

So I'm trying to run my code and I'm receiving the below errors. So then I open another terminal and try installing the dependencies and it's saying it is unable to locate the package on all of them I've searched and searched for answers for like 2 hours now and tried everything I can with no luck a...
Yoe
-1

votes
2

answer
15

Views

Windows 7 doesn't boot after Ubuntu installation

I had Win 7 installed on one of 2 HDD disks, the other one was just extra storage. On top i have a small sdd attached to my pc, which was not used at the moment so i had the idea of installing linux ubuntu on it. At first i tried installing it and managing the different drives in the install client,...
Veit Starost
0

votes
0

answer
7

Views

Running Keras?MNIST example on Ubuntu 18.04 - GPU error

I was running the following Keras/TensorFlow code code after setting up Anaconda 2018.12 on Ubuntu 18.04. I have Nvidia driver 390.116 and have a GTX 1070 GPU. Howevr, when I try to run this simple MNIST example import tensorflow as tf mnist = tf.keras.datasets.mnist (x_train, y_train),(x_test, y...
cmillsap
0

votes
0

answer
7

Views

PANIC: Missing emulator engine program for 'x86' CPU. ON UBUNTU

I cant start my emulators. I tried to start it from AVD manager but got this error. than I tried to lounch it from Terminal but now I get this.
N.JB
0

votes
0

answer
4

Views

Mplabx 5.15 on Ubuntu 18.04 can not use ICD 3

I keep getting this error with ICD 3 when attempting self test: Could not connect to the selected hardware tool. Please make sure the tool is not being used by another project in MPLAB X. The device works fine under Ubuntu 12.04. Mplab can see the ICD3 device because it gets the correct serial numb...
Mike Rosing
0

votes
0

answer
2

Views

Tensorflow runtime could not load due to libcublas.so.10.0 not being found

This has been the second of my two unsucessful attempts to install Tensorflow. Earlier I tried installing it with CUDA 9.0 but I never found a file for Cuda in my /usr/local directory. I then followed this tutorial but with Cuda 10.1 (basically the runfile method) I did manage to follow the exact...
anshuman_kmr
0

votes
0

answer
3

Views

Run Scripts at Boot Time in Ubuntu 18 Desktop

I want to assign static IP address in Ubuntu, but everytime I reboot it, the settings are reset. How will I run the scripts at boot time? Below are my code: ifconfig eth0 192.168.5.2 netmask 255.255.255.0 route add default gw 192.168.5.1
Eliyah
0

votes
0

answer
6

Views

Omnet++: Uavsim Simulation can not run

I am trying to run Uavsim (Omnet++ based drone simulator) on Ubuntu 18.04 but getting some error when I trying to open it with 'omnetpp' command. It shows a message box and says that 'An error has occurred. See the log file /home/XxX/Desktop/uavsim/ide/configuration/1551888566822.log.' !SESSION 2019...
user3241429
-1

votes
0

answer
4

Views

Program's icon showing twice on taskbar. It's not doubly installed. How can I just have the one?

I downloaded and installed Firefox Developer Edition, for which I made an executable desktop icon. I moved it to ~/.local/share/applications, and this is what it reads: #!/usr/bin/env xdg-open [Desktop Entry] Version=1.0 Type=Application Terminal=false Icon=/home/name/.local/share/umake/web/firefox-...
pikecha
1

votes
1

answer
978

Views

The system tray is not supported on the current platform?

I'm trying to make a System Tray application on Ubuntu 18.04 using Java. This is the code that I'm executing: import java.awt.*; import java.awt.event.ActionEvent; import java.awt.event.ActionListener; public class App { static{ System.setProperty('java.awt.headless', 'false'); } public static void...
user3676224
1

votes
2

answer
220

Views

Makefile:649: *** missing separator. Stop

I've read an checked out all the answers to the same kind of error I seem to have. After implementing the solutions of adding a tab here or there as suggested and checking for spaces I cannot seem to get the makefile working. This comes from the makefile of MDM display manager (https://github.com/li...
Dorilds
1

votes
2

answer
1k

Views

Installing node-sass on ubuntu 18.04 returns error

I'm trying to install node-sass on ubuntu, beacuse I want to use sass-autocompile, but even when I try to compile that sass file in atom (just when I save it) It returns this error: `fs.js:904 return binding.readdir(pathModule._makeLong(path), options.encoding) Error: ENOENT: no such file or direct...
SenTisso
1

votes
1

answer
2.1k

Views

Can't install CURL on Ubuntu 18.4LTS (libcurl4 required) but installing it remove libcurl3 and thus mongo not working properly

Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been mov...
Maaz Ali
1

votes
1

answer
1.3k

Views

Upgrade CMake version installed with Android-Studio Ubuntu 18.04

I recently installed Android Studio on Ubuntu 18.04 to do some native C++ development for Android. While compiling a project that required cmake 3.9 or higher (due to cmake dependencies) I found that the cmake version installed by Android Studio was only version 3.6. Is there a clean way to upgrade...
skonz
1

votes
1

answer
100

Views

Embed RPATH instead of RUNPATH in when building shared-objects on Ubuntu 18.04

I have a Linux shared-object, which links dynamically with some shared-objects, and some of them in turn link dynamically further with additional shared-objects, requiring indirect dynamic linking. To find those SOs I embed an RPATH header into my top-level SO by passing linker flags to G++ as in: -...
YitzikC
1

votes
1

answer
498

Views

curl and wget not working with https sites after upgrade to ubuntu 18.04.1

Seems to be a openssl related issue. Anyone have any ideas as to what this is? Note that the url works in a browser. With wget: # wget -d https://deb.nodesource.com/setup_8.x DEBUG output created by Wget 1.19.4 on linux-gnu. Reading HSTS entries from /home/user/.wget-hsts URI encoding = ‘UTF-8’...
Ziffusion
1

votes
1

answer
228

Views

Ubuntu 18.04.1 on VMware Fusion 11 results in kernel panic with Packer

I am trying to create a VMware virtual machine using Packer, with Ubuntu Server 18.04.1 as guest OS. However, creation of the VM fails after having sent the boot command. The specific error seems to be related to APIC, although the boot command contains noapic. Also, setting acpi=off does not change...
Golo Roden
1

votes
2

answer
63

Views

Python2.7 program not working when runned by crontab

Hardware setup (computer, etc) Ubuntu server 18.04.1 Serial To Usb Converter with 8 ports Python version 2.7.15r1 Python program description When the program starts to create some threads: Create one thread for the Modbus server. Run 1 thread for each serial port connected (/dev/ttyUSBn) and start r...
Carlo Zanocco
1

votes
2

answer
73

Views

Running rake tasks from crontab

I have run into a problem that I can't imagine a solution for, and has had me stuck for a week. I have the following two lines in sudo crontab -e. * * * * * echo 'crontab can log to reports' >> /var/log/mazer-reports.log * * * * * /bin/bash -l -c 'cd /home/deploy/shopify_pull_and_store && /home/depl...
Colin Brogan
1

votes
2

answer
27

Views

Migrate conda environment to a machine that does not have internet (or fast internet)

I am using conda with python and installed a lot of dependencies in an environment. I need to migrate the environment to another PC that has a very slow internet. So rather downloading packages is there any way to take the dump from working machine and put to the new machine. The operating system I...
Gokul C
0

votes
0

answer
2

Views

Trouble installing Caffe in Ubuntu 18.04

I am trying to install Caffe in Ubuntu 18.04 but facing some problem. After installing dependencies mentioned below when I run the command make all -j4 I get this error Dependencies Installed CUDA 9.0 CuDNN 7.4 $ sudo apt install python3-opencv $ sudo apt-get install libatlas-base-dev $ sudo apt-get...
Atinesh
0

votes
0

answer
4

Views

No welcome page after openCPU install in fresh Ubuntu 18.04 instance

I am trying to install OpenCPU 2.1 on a fresh free tier AWS server. I followed [https://aws.amazon.com/getting-started/tutorials/?awsf.getting-started-content=use-case-tmt%23websites-apps], and launched a Ubuntu Server 18.04 LTS (HVM), x86, free tier server, and obtained public and private IP's. T...
Stef van Buuren
1

votes
1

answer
5.1k

Views

Remove Docker on ubuntu 18

I had installed docker in ubuntu 18 and now wants to remove everything for a clean install. Had used : sudo apt-get install docker.io This stackoverflow thread (though not meant for my exact installation) has a part-solution: docker remove answer The only problem is that it doesn't mention how to...
user3087182
0

votes
0

answer
17

Views

Cannot install php7.2-fpm on the latest Ubuntu “18.04.2 LTS (Bionic Beaver)”

It looks like PHP 7.2 now comes out of the box on Ubuntu 18.04 but there are 2 versions: 7.2.3-1ubuntu1(base) and 7.2.15-0ubuntu0.18.04.1(security). When I try run apt install php7.2-fpm I get: # apt install php7.2-fpm Reading package lists... Done Building dependency tree Reading state information....
Costas
1

votes
1

answer
1.1k

Views

lower_case_table_names=1 on Ubuntu 18.04 doesn't let mysql to start

I have installed mysql community server 8.013 on ubuntu 18.04 and I have the following issue. I want to set lower_case_table_names=1 in order to have case insensitive table names in my db. I edited /etc/mysql/mysql.conf.d/mysqld.cnf and added the following line under [mysqld] lower_case_table_names=...
Christoph Adamakis
0

votes
0

answer
4

Views

unable to find valid certification path to requested target. No security certificates are applied and yet I get this error. Why?

A test build of a jdk10 app is deployed on a machine. No SSL certificate is applied. This is a fresh set up. And yet I get below error when I try to run the app. Database and app are on the same machine. So is tomcat/nginx etc. Caused by: sun.security.validator.ValidatorException: PKIX path building...
Dhiraj
2

votes
2

answer
98

Views

virtualenv creates directory called 'local' on Ubuntu

If I create a virtualenv with Ubuntu 18.04, then a directory called local gets created. virtualenv test-env cd test-env ls -l local/ Output: lrwxrwxrwx 1 foo foo 30 Jan 30 10:47 bin -> /home/foo/tmp/test-env/bin lrwxrwxrwx 1 foo foo 34 Jan 30 10:47 include -> /home/foo/tmp/test-env/include lrwxrwxrw...
guettli
0

votes
0

answer
4

Views

Problem running the Pentaho kitchen shell script from linux command line

I'm able to run the job on spoon GUI interface but, while I'm trying the run the kitchen shell script the job fails. Could anybody please explain the problem Shows the error message 2019/01/31 15:07:20 - Spoon - ERROR (version 8.1.0.0-365, build 8.1.0.0-365 from 2018-04-30 09.42.24 by buildguy) : Un...
aditya goud
0

votes
0

answer
6

Views

php base_convert works fine locally, but not on ubuntu 18 LTS server (Laravel 5.7)

Hell internet world I bring another weird and wonderful question to you today. See the code blow, locally (using Laravel's inbuilt php serve functionality, this outputs the following: Which is the desired result [2019-01-31 14:33:07] local.DEBUG: >>: q [2019-01-31 14:33:07] local.DEBUG: --: q [2...
The-WebGuy
1

votes
1

answer
45

Views

Java mysql-connector ClassNotFoundException despite filing posts

Still get compile error ClassNotFoundException from com.mysql.cj.jdbc.Driver from java-8 mysql-connector-java-5.1.147.jar and mysql-connector-java-5.1.47-bin.jar (though most postings say it is the bin.jar that is needed) I unpacked the tar file and copied the two mysql-connector jar files to /usr/l...
user2976382
0

votes
1

answer
32

Views

Ubuntu Preseed and Templating

I'm loading and executing this bash file from my preseed file on Ubuntu 18.04.1. The install works perfectly and my bash file is downloaded and executes but with errors. Error message: 'activation/ask does not exist'. I tried troubleshooting this and reading the debconf dev configuration but can't r...
user3323307
0

votes
1

answer
51

Views

Installing OpenMx package in R on Ubuntu 18.04LTS

I get the following error when trying to install (install.packages('OpenMx')) OpenMx in R on Ubuntu 18.04. I am not familiar with compiling C code, so I ask that you 'dumb it down' for me a bit. Installing package into ‘/home/adam/R/x86_64-pc-linux-gnu-library/3.5’ (as ‘lib’ is unspecified)...
Adam K
1

votes
2

answer
1.7k

Views

Ubuntu 18.04 - Error response from daemon: Get https://registry-1.docker.io/v2/: proxyconnect tcp: tls: oversized record received with length 20527

I am having issue with Docker on Ubuntu 18.04 with docker-ce. While pulling a container: $ docker pull nginx or while trying to login $ docker login I get the following message: Error response from daemon: Get https://registry-1.docker.io/v2/: proxyconnect tcp: tls: oversized record received with le...
0

votes
0

answer
2

Views

How to install AWS CloudHSM on Ubuntu 18.04 TLS? (requires libjson-c2 but only libjson-c3 available)

I am trying to install Amazon AWS CloudHSM on AWS EC2 instances running Ubuntu 18.04 LTS. The instructions from Amazon seem to require an older library libjson-c2, but only the newer library libjson-c3 is available for Ubuntu 18.04 LTS. Amazon link: https://docs.aws.amazon.com/cloudhsm/latest/usergu...
David Jones
2

votes
1

answer
109

Views

The JAVA_HOME environment variable is not defined correctly, but it is defined correctly! Ubuntu 18.04.01

I am trying to run maven on Ubuntu. Every time I run something like mvn -v I get: 'The JAVA_HOME environment variable is not defined correctly This environment variable is needed to run this program NB: JAVA_HOME should point to a JDK not a JRE'. The thing is that I have set JAVA_HOME correctly. In...
Nikos Leventis
0

votes
2

answer
13

Views

Add to $PATH with Shell Script [duplicate]

This question already has an answer here: How to permanently set $PATH on Linux/Unix? 21 answers I want to add PATH on Linux Ubuntu 18.04 from file path.sh , my file include : #!/bin/bash export PATH='$PATH:/root/.local/bin' chmod+x path.sh , but when i run it ./path.sh Path not add when i type ech...
Mehran Goudarzi
2

votes
3

answer
25

Views

git commands are incorrectly silent: git 2.17.1 on Ubuntu 18.04.1 LTS

I just upgraded my OS and git, and commands such as git log, git diff, and git branch are incorrectly silent. $ git clone [email protected]:ropensci/drake Cloning into 'drake'... remote: Enumerating objects: 482, done. remote: Counting objects: 100% (482/482), done. remote: Compressing objects: 100% (3...
landau
0

votes
2

answer
6

Views

ping: google.com: Temporary failure in name resolution

ping: google.com: Temporary failure in name resolution This problem is what's happing when trying to ping a domain instead of a IP, at this moment in the resolve.conf it has the 127.0.0.57 IP, tried adding this nameserver 8.8.8.8 and it fixed the problem on the short term, im going to be running a d...
Nicolai Jacobsen

View additional questions