Questions tagged [homebrew]

1

votes
3

answer
411

Views

Error when installing Homebrew: dyld: Library not loaded: @rpath/libssl.1.0.0.dylib

I'm trying to install Homebrew on my Mac os (macOS Mojave Version 10.14.3) And I keep getting the following error (the exact message I see in my terminal): dyld: Library not loaded: @rpath/libssl.1.0.0.dylib Referenced from: /Users/[my_machine_name]/anaconda3/lib/libssh2.1.dylib Reason: image not fo...
Pedram
1

votes
2

answer
699

Views

How to run multiple brew commands with one line?

I often run the following commands, one after another. I wonder if it can be done with one line? brew update brew upgrade brew cleanup
Stickers
1

votes
1

answer
819

Views

Where is snappy installed via homebrew

I've installed snappy (I think) with brew install snappy. And brew info snappy gives snappy: stable 1.1.7 (bottled), HEAD Compression/decompression library aiming for high speed https://google.github.io/snappy/ /usr/local/Cellar/snappy/1.1.7_1 (18 files, 118KB) * Poured from bottle on 2018-04-04 a...
Nic Cottrell
1

votes
2

answer
272

Views

Newbie difficulties with graphicsmagick and jpeg decode delegates

I am having difficulty trying to get graphicsmagick to work. New to the coding world =] I think I might have botched up my installation by not using brew to install. I have an image on my /Desktop; 'sign.jpeg' Here's what I get when I try to identify (or resize) the image: Admins-iMac:Desktop admin$...
Ticdoc
1

votes
0

answer
175

Views

MongoDB installation throwing error with brew

Hey I have tried everything out there and can't seem to find a solution to this. When I try installing MongoDB using brew on my mac with brew install mongodb in the terminal I get the following error: mongodb: A full installation of Xcode.app 8.3.2 is required to compile this software. I have ran a...
Mohammed
1

votes
1

answer
86

Views

gfortran 7, READ command and libraries

I have recently upgraded to gfortran 7.2 from 6.x using homebrew on OSx. I am now getting errors from the READ statement that I was not getting previously. A minimal example that generates the error is: PROGRAM read_test IMPLICIT NONE CHARACTER :: c INTEGER :: i c='1' READ(c,*) i WRITE(*,*) i END PR...
Mead
1

votes
0

answer
29

Views

How to modify osx homebrew formula to run on wider variety of systems?

I am installing the openssl package via osx homebrew. I however need to tweak the compilation process, but i cannot even find where/how homebrew is compiling my packages. I specficially would like to see what CFLAGS and most importantly the value of the -march= flag. I looked in the logs ~/Library/L...
horseyguy
0

votes
0

answer
7

Views

Cannot do any Brew commands on Mac High Sierra

I uninstalled and reinstalled brew, trying to fix a problem I had with it, but now it won't work at all. Any brew command gets me permission denied. I can't even run brew doctor. I tried these commands. sudo chown -R '$USER':admin /usr/local sudo chown -R '$USER':admin /Library/Caches/Homebrew First...
beandaddyo
1

votes
1

answer
685

Views

How do I get Mac to install php with a php.ini file?

I'm using Mac High Sierra. I need to install php with the php.ini file installed. I ran the following command without errors: brew install php71 --build-from-source However, when I search for a configuration file, I get nothing: localhost:stratum-php-master davea$ php -i | grep 'Loaded Configurati...
Dave
1

votes
1

answer
2.1k

Views

Install opencv 3.3.1 (previous version) with homebrew

I have an issue with not being able to use an integral piece of software due to its dependancy and being compiled with a previous version of opencv. When installing new opencv using homebrew brew install opencv I am getting the latest version 3.4. Is there anyway to install a previous version? Edit:...
user3357649
1

votes
0

answer
13

Views

Does homebrew formula has uninstall hook?

My formula need to persist configuration file between upgrade, so I symlink those configuration directory to /usr/local/var/foo-app. I would like to know, does homebrew formula has hook to do clean up when user uninstall the formula. Or Its okay to left /usr/local/var/foo-app there.
Morty Choi
1

votes
1

answer
805

Views

Install A Specific Version of Boost With Homebrew on Mac

I am trying to install an older version of Boost on my Mac using Homebrew. I am using: brew install [email protected] And receiving error: Error: No available formula with the name '[email protected]' I have performed: brew search boost And I can see that I have all versions back to 1.55 installed. Is there a wa...
Alan Carr
1

votes
1

answer
567

Views

How to fix Brew Install error. Xcode 8.3.3 outdated install Xcode 9.2 on High Sierra

Error: Your Xcode (8.3.3) is too outdated. Please update to Xcode 9.2 (or delete it). Xcode can be updated from the App Store.
Faisal
1

votes
1

answer
578

Views

Failing to build Ruby 2.5.0 with rbenv and ruby-build

So I am trying to install ruby 2.5.0 with rbenv and this is my issue: $ rbenv install 2.5.0 ruby-build: use openssl from homebrew Downloading ruby-2.5.0.tar.bz2... -> https://cache.ruby-lang.org/pub/ruby/2.5/ruby-2.5.0.tar.bz2 Installing ruby-2.5.0... ruby-build: use readline from homebrew BUILD FAI...
Luke
1

votes
1

answer
804

Views

pip2 causes ImportError: Entry point ('console_scripts', 'pip2') not found

I installed python 2 by brew install python I can localise pip2 but not use it. In the terminal i get an error as: [email protected]:~$ pip2 Traceback (most recent call last): File '/usr/local/bin/pip2', line 11, in load_entry_point('pip==9.0.1', 'console_scripts', 'pip2')() File '/usr/local/lib/pytho...
Elena
1

votes
0

answer
11

Views

How to upgrade a formula of Homebrew as a package developer?

I have created a Homebrew tap which has a single formula to install my package Foo. Foo is upgraded now, and I am wondering what I should do to upgrade the formula as well? In other words, what should I tell Homebrew, so users can run brew upgrade to upgrade Foo?
Jay Wong
1

votes
1

answer
43

Views

brew - mysql is not available unless the installation account is signed on

I have set up an environment (apache/php/mariadb) on a Mac using Homebrew. All is working great as long as the account I used to perform the install is signed onto the Mac. If the Mac is started and no account has logged on, then I’m unable to access the database over the network. If one of the...
mike
1

votes
0

answer
98

Views

brew bundle command takes long time to install upon updating the Brewfile

brew bundle command takes really long time to install updated Brewfile. I have added a sourcetree to Brewfile cask 'sourcetree' and then run the command brew bundle. It took really long time to complete installation. Homebrew version: Homebrew 1.5.4 Does anyone experience this behaviors from Brew?
forethought
1

votes
0

answer
964

Views

pip3 cannot be found after installing python3 and pip3 on a mac

python2 is installed on every mac and I installed python3 and used it a lot with the standard libraries. Now I wanted to use pip3 as I did with pip and it says: -bash: pip3: command not found I downloaded get-pip.pyfound in StackOverflow's answers and with installing it I got: Requirement already up...
TravelTrader
1

votes
0

answer
1.5k

Views

PHP72 MongoDB driver with Homebrew on OSX

I have a question that might point to a misunderstanding I have with Homebrew in relation to MongoDB: I am running XAMPP (version) with PHP 7.2.1 (which I want to use) on Mac OSX 10.12.6 (Sierra). I installed MongoDB and created configuration and data storage folder. It runs fine on command line (wh...
RalfB
1

votes
1

answer
558

Views

Attempted install of Python 3 via homebrew fails on Mac OS X Sierra

I'm trying to install Python 3 alongside 2.7 with Homebrew but am receiving an error message I can't find a resolution to. When attempting brew update && brew install python3 I get the following error: Error: python 2.7.12_2 is already installed To upgrade to 3.6.4_3, run `brew upgrade python` I wan...
elti
1

votes
1

answer
223

Views

Laravel 5.6 envoy error when called from controller

I'm trying to use envoy from laravel to call some scripts on my server. Right now I'm doing it with a virtual machine installed on my mac. I'm trying to run my envoy scripts from a controller as follow: function __construct() { $command = '/Users/test_user/.composer/vendor/bin/envoy run test --filen...
killstreet
1

votes
0

answer
128

Views

Problems with homebrew and Macports

So I try to install the ruby 2.3.3 and was informed that: Warning: port definitions are more than two weeks old, consider updating them by running 'port selfupdate'. ... ruby-2.3.3/port_install.log Requirements installation failed with status: 56. So, I do a brew doctor and tells me: Warning: You ha...
rld
1

votes
0

answer
56

Views

How to uninstall redundant version of python3

The situation I face is that I seem to have two python3.6s on my MacBook Pro, one with the .dmg installer from the official python website, and one installed via Homebrew ( inferred by others, I don't remember whether it is right or not) : TreaserdeMacBook-Pro:~ treasersmac$ python3 Python 3.6.0 (v3...
Treaser
1

votes
1

answer
1.6k

Views

Can't remove old version of ChromeDriver on MacOS

I have a very annoying problem with ChromeDriver. I need to use version 2.36, but I currently have 2.35.528157 (when doing chromedriver -v). I have already done: brew upgrade chromedriver Which ran successfully, however according to my terminal, I still have 2.35.528157 I then did a brew cleanup chr...
theJuls
1

votes
1

answer
265

Views

brew update only gives an older version of openssl

I have openssl 1.0.2o installed, but I need a newer version. Trying to use brew to do the update, but didn't work. brew update still gives an older version of openssl, 1.0.2o, but not the standard version, which is 1.0.2j now in my understanding. brew update brew upgrade openssl Error: openssl 1.0...
user1470393
1

votes
0

answer
25

Views

Installing Python2.7 packages with Homebrew

When I try to install wxPython3.0.2.0 with Homebrew 1.5.13 on macOS High Sierra 10.13.2, it installs the package defaultly in Python3. How can I make Homebrew install it in Python2.7?
c1der c1der
1

votes
0

answer
444

Views

Octave GUI not launching on MacOS 10.11

I am currently using MacOS 10.11.6. I installed the latest Octave as the wiki explains using Homebrew, specifically the tap homebrew/core. When I launch it from the terminal, everything works fine, and no error is raised except for the fact that the GUI does not launch (even using the --force-gui fl...
donatorolo
1

votes
1

answer
533

Views

Since homebrew updated me to [email protected] from php71 my php extensions have become disabled

Since homebrew updated me to [email protected] from php71 my php extensions have become disabled: imagick opcache xdebug I've read that these are now included and cannot be installed separately. Before, running brew install php70-opcache etc. enabled the extensions. How do I re-enable these PHP extensions? Se...
24ma13wg
1

votes
1

answer
600

Views

OSX: importing gi from pygobject3: “ImportError: cannot import name _gi”

I had a working python program that uses GTK3 as installed with homebrew. After updating my OSX system I now get the error: import gi File '/usr/local/lib/python2.7/site-packages/gi/__init__.py', line 42, in ImportError: cannot import name _gi The minimal example that produces this error would...
krumpelstiltskin
1

votes
1

answer
194

Views

Installing mcrypt and intl using Hombrew/Core

I am trying to install mcrypt and intl on my Mac using hombrew but the formulea are not valid since homebrew/php has been deprecated and merged into homebrew/core. I have installed the latest verion of php (brew install php) and it seems that mcrypt and intl are not included in the modules. Has any...
ywtstewart
1

votes
1

answer
50

Views

bash: brew command is not showing any output

I accidentally placed the > character before the brew command (Homebrew), after that, I'm not sure if the brew commands are being executed because they don't output anything. I've restarted terminal and computer but it continues the same. Mac OS X Sierra
htafoya
1

votes
0

answer
414

Views

Run MongoDB 3.6 as a brew service with auth

MongoDB v3.6.4: After migrating from mongo 3.4 to 3.6 From the shell I am able to startup the db and connect to it with authentication. mongod --auth --port 27017 --dbpath /data/db However when I start mongodb with brew the authentication does not work and it is not possible to authenticate manually...
sznrbrt
1

votes
1

answer
45

Views

Mac brew arangodb delaying start log file path

I have installed arangodb through brew. I am new to both mac and arangodb. Right after installation of arangodb I could start stop it through brew services. But since yesterday that didn't work. However arangod start worked. Today its taking really long time for the service to start up $ arangod sta...
Neel Basu
1

votes
1

answer
42

Views

Contradiction of node versions on Mac OSX

I wanted to run Angular6 which has been released a couple of days back. So the system gave me an error that my node version was lower than 8.9. So I did the following steps. But it seems the system has two versions of node running independently. Checked node version Node present in brew list Tried T...
MadaZZ
1

votes
0

answer
153

Views

Flutter says Brew is not installed

I have installed homebrew but flutter says it is not installed: iOS toolchain - develop for iOS devices (Xcode 9.3) • Xcode at /Applications/Xcode.app/Contents/Developer • Xcode 9.3, Build version 9E145 ✗ Brew not installed; use this to install tools for iOS device development. Download brew a...
M.Luffy
1

votes
1

answer
264

Views

Unable to install memcached via homebrew due to deprecation. PECL doesn't work either

So our friends at Homebrew have gone and changed things. They've deprecated Homebrew/PHP. That's fine, that's what we developers do. I was able to successfully install PHP 5.6 using Homebrew on a fresh installation of OS X High Sierra. I'm trying now to install memcached and mcrypt, but with the...
noctufaber
1

votes
0

answer
193

Views

OS X can't update PHP by homebrew

I want to install PHP7.2 I ran the command below: $ brew install [email protected] Error: You are using macOS 10.10. We (and Apple) do not provide support for this old version. You may encounter build failures or other breakages. Please create pull-requests instead of filing issues. My PC can't update anymore...
user2006734
1

votes
1

answer
39

Views

brew list failed with the error: Device error @ io_fillbuf - fd:7

My system is macOS High Sierra 10.13.2. when I run brew list, I get an error: $ brew list /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': Device error @ io_fillbuf - fd:7 /usr/local/Homebrew/Library/Homebrew/build_environ...
wei zhao
1

votes
0

answer
44

Views

brew installing npm and node in unknow place

I just install the node from there official site. It was working fine for me.t hen I need to run npm commands without sudo so I follow this up john papa way to set it but it fails in the middle I mentioned in the pic. and after that when I install it again with brew it installed and then I check n...
Amjad Mehmood

View additional questions