Questions tagged [cocoapods]

2

votes
0

answer
9

Views

Update Facebook SDK issue

I use Facebook SDK login feature. In console written 'Your Facebook SDK is out of date. We recommend upgrading to the latest Version 4.37.0, to ensure your app's performance is not affected and to take advantage of our newest features!' I updated SDK pods to 4.4.1, but this warning still there. Any...
Artyom Vlasenko
1

votes
3

answer
625

Views

The bundle UITests couldn’t be loadedbecause it is damaged or missing necessary resources. Try reinstalling the bundle

my pods are here # Uncomment the next line to define a global platform for your project platform :ios, '9.0' target 'myAPP' do # Comment the next line if you're not using Swift and don't want to use dynamic frameworks use_frameworks! # Pods for myAPP pod 'SwiftMessages' pod 'IQKeyboardManager' pod...
Jibran SiddiQui
1

votes
1

answer
69

Views

Build error integrating Clevertap to a Reactnative Application

I'm trying to integrate clevertap with native react and when I include 'use_frameworks!' in cocoa pods to be able to use #import a compilation error is generated in UMLCore Already make the link of the application with clevertap Install all the package throught 'yarn install' Install the pods thr...
Carlos Cabezas
0

votes
0

answer
5

Views

Why Cocoapods adds “$(PLATFORM_DIR)/Developer/Library/Frameworks” as header search path?

I'm debugging a warning I have on my xcode project and I ended up looking at the source code of Cocoapods. For each target that includes XCTest or SenTestingKit, Cocoapods adds a this entry as FRAMEWORK_SEARCH_PATHS (source) $(PLATFORM_DIR)/Developer/Library/Frameworks On my Mac this folder doesn't...
IgnazioC
1

votes
3

answer
935

Views

How to specify specific source for a certain pod?

Although I believe this is harmless, warnings quite irk me. So I'm using a very specific version of TwilioChatClient together with TwilioClient. These two specific versions are what Twilio have been using in their sample projects. Anyways, the warning when installing / updating pods: [!] Found multi...
Glenn
1

votes
1

answer
38

Views

What am I missing with my pod install? Xcode Build fails Azure Devops Pipeline

I am using an Azure Devops Build pipeline to build my Xcode workspace. It builds fine locally as well as if I import the repo and use it in AppCenter to build. But I want to use an external Git, thus using a Build Pipeline. It is pretty simple in terms of steps. 1 - Get Repo (finishes this step) 2 -...
K2SO Ghost Spirit
1

votes
0

answer
19

Views

Cocoapod modules not available in Pod Example project

I created a new Pod project and included an example project when running through the pod lib create ProjectName setup steps. I've added some classes to the pod and although I am able to use them in a separate project that includes my pod either locally or remotely, I can't use them in the Example pr...
Cbas
1

votes
0

answer
60

Views

how to share Alamofire in widget

I'm making some weather app. and i want to show weather info on widget too So i tried to import Alamofire in Widget's ViewController but it couldn't find module I also check tutorial from other blog or website, but in my project i cannot find Alamofire in `Linked Frameworks and Libraries like this...
Dongkun Lee
1

votes
1

answer
394

Views

Cordova plugin with Cocoapod dependency is not working properly

I am new to Cordova plugin implementation. I am creating a Cordova plugin that provides Web Socket support to the Cordova App. For Android platform everything is working fine. But for iOS, using Swift, I am stuck. For iOS (using Swift), to work with WebSocket, I am using SwiftWebSocket client librar...
KavitaDev
1

votes
0

answer
177

Views

Cocoapods use_frameworks with Objective C and Swift mixed project causes issues

I have just started working on Swift 4.0 with my current Objective C project. Everything went fine until I wished to use pods for ALCameraViewController which is built in swift and my previous pods are in Objective C, so I can't enable 'use_frameworks!'. Even if I enable it my project builds success...
Paras Gorasiya
1

votes
1

answer
264

Views

set up a carthage/cocoapod project to distribute multiple dependencies

Sorry if these questions are basic/dumb. I haven't had to do any framework setup stuff in the past. I've just contributed to projects in the past. I want to distribute different parts of an SDK with Cocoapods and Carthage. For example, github 'MyOrg/Core' -> Has interfaces I want to use in Small...
Crystal
1

votes
1

answer
105

Views

RealmSwift 3.0.2 and Swift4 issue

Using RealmSwift-3.0.2, Cocoapods-1.3.1, Swift-4.0.3, iOS-11.2, XCode-9.2 I am trying to create a Realm object (as I always did the last three years). But since Swift4, something seems off ! I get the following Error-message: libc++abi.dylib: terminating with uncaught exception of type NSException B...
iKK
1

votes
1

answer
205

Views

React Native RTCAnimation not found

I clone git and run in ios but RTCAnimation not found I use pods to code: # Uncomment the next line to define a global platform for your project # platform :ios, '9.0' pod 'Yoga', :path => '../node_modules/react-native/ReactCommon/yoga/Yoga.podspec' pod 'React', :path => '../node_modules/react-nativ...
salution
1

votes
0

answer
110

Views

Conflicting Variables in pods

I am using the pusher pod and the starscream pod. When I try to use the class/type Websocket to open a socket using starscream, it causes issues because it conflicts with something in pusher. I get the error 'Cannot invoke WebSocket with an argument list of type (url: URL).' As soon as I get rid of...
Nevin Jethmalani
1

votes
2

answer
255

Views

Undefined symbols for architecture arm64: linker command warning

I updated my pods, and then after closing the project and reopening it, I received this error that I've been trying to figure out for 5 hours, and nothing has worked for me. I've been told to change the architectures, but all that I've tried isn't working, and I'm struggling a lot. Here is my pod fi...
vApp
1

votes
0

answer
416

Views

cordova ios cocoapods requirement not met

I am trying to run build default cordova app 'hello' but when do do cordova requirements the message contains the following: Requirements check results for ios: Apple macOS: installed darwin Xcode: installed [object Object] ios-deploy: not installed ios-deploy was not found. Please download, build a...
fred
1

votes
1

answer
216

Views

cocoapods lint - Encountered an unknown error

I Hope someone can help me out here, I'm going nuts! I had a working SDK submitted to Cocoapods and now lint is not building properly. Here is my PodSpec: Pod::Spec.new do |s| s.name = 'SpotIM' s.version = '1.1.9' s.summary = 'This SDK allows you to integrate SpotIM int...
Hernan Arber
1

votes
1

answer
410

Views

Xcode 9.2 Shell Script Invocation Error

I am facing Shell Script Invocation Error only when I am trying to Archive my project. But my project was running good in Simulator and in Real Device. How to solve this issue? I am using Xcode 9.2 in MacOS High Sierra.
Kavin Kumar Arumugam
1

votes
2

answer
59

Views

adding ios core framework to podfile

I added a pod to my Podfile and got compiler errors when building: Undefined symbols for architecture arm64: '_OBJC_CLASS_$_CLLocation', referenced from: objc-class-ref in MoPubAdapter(GADMAdapterMoPub.o) ld: symbol(s) not found for architecture arm64 clang: error: linker command failed with exit co...
Joseph
1

votes
1

answer
98

Views

Language not recognised in .travis.yml of project generated by CocoaPods

I create a CocoaPods project in Swift. But the build in Travis always fail. The error message is: The command 'rake' exited with 1. I found the language in Travis is recognised as Ruby instead of Swift (Objective-C). Here is the screenshot: My .travis.yml is: osx_image: xcode7.3 language: objective-...
Bagusflyer
1

votes
0

answer
61

Views

Uber app login not redirecting to my app if Uber app is in background and not in home screen

I am implementing the Uber ride request feature in my app (using Uber pod). Then I have to login to Uber from my app. If the Uber app is not in the logged in state or in home screen, the login process from my app to Uber app is working perfectly. I will get the callback in my app delegate. Everythi...
Zeesha
1

votes
1

answer
42

Views

What's the best way to bundle my iOS SDK?

We're developing an SDK for a private service. We have two business plans that we aim to achieve: Shipping our SDK as a proprietary service, so third party developers can receive our SDK without being able to extract its source code. Shipping our SDK as an open library for certain entities, so they...
Paula Mamdouh
1

votes
1

answer
252

Views

Change Other Swift Flags gives build error

I'm creating multiple targets for development, test, production, QA etc.. When I do that I want to differentiate this targets by changing 'other swift flags'. As default, It shows as in below screenshot. I want to change that '-D' to 'Prod'. I think because I use Cocoapods, I'm getting build error....
Mr Some Dev.
1

votes
2

answer
1.3k

Views

Module not found - cocoapods

I'm trying to pod install this library into my project's (lets say child xcodeproj) parent project (lets say Parent xcodeproj). Child .xcodeproj has its own podfile where I have added RxSwift, RxCocoa, Realm and this GeoSwift library. Here is the cocoapods file as show below source 'https://github.c...
DesperateLearner
1

votes
0

answer
181

Views

iOS - Debug my Framework in my App XCode project

I have created an iOS Framework 'MySDK' which exposes API to my App 'MyApp' to send an Alert to my backend. I'd like to walk through the Alert sending code from XCode in debugger. MySDK and MyApp have their own workspaces. I build my SDK in XCode, and then I build my App with Cocoapods (do a pod in...
CoolDocMan
1

votes
1

answer
74

Views

nobody can get cocoadocs page for swift framework

Trying to post to CocoaPods, but when the project goes through it doesn’t generate docs (site + docs button, instead of expand). Alternatively, when I specify a docs url the docs button doesn’t work either. According to the guides, it seems like jazzy isn’t parsing, but when I run: jazzy or......
Mercutio
1

votes
0

answer
139

Views

Swift Too many Cocoa pods?

So I am creating an app that uses Firebase, Google maps SDK, Core location and loads of other little third party things going on, but is there a point where all these pods become too many? What are the negatives to having this many pods other than the obvious large project and IPA file size? To give...
Niall Kiddle
1

votes
0

answer
325

Views

Ignore warnings for all pods

I put inhibit_all_warnings! at the top of my pod file then ran pod install and still see warnings in XCode. Update: I was able to get it to kinda work by cleaning the project after pod installing, however, I still see warnings sporadically.
bj97301
1

votes
1

answer
44

Views

Our Cocoapods library page is redirected to github page

I created a new pod, and pushed it to cocoapods by issuing command, pod trunk push AIQKit.podspec After a while, I go to cocoapods.org, can find it by searching AIQKit. but when I tried access https://cocoapods.org/pods/AIQKit I was always redirected to github page even after I updated 4 versions i...
Leo Hwang
1

votes
2

answer
102

Views

MapBox Navigation frameworks not installing correctly via CocoaPods

I am trying to install the MapBox Navigation SDK to my Xcode project, but I keep running into a problem. I previously installed the generic MapBox SDK via cocoapods without issue, but when adding the Navigation SDK to my podfile and updating, many of the frameworks installed are appearing as red (im...
David Chopin
1

votes
0

answer
15

Views

a Framework is using a library I am using

I am managing my library with cocoapod. and there are some dependency, a third party library CocoaAsyncSocket is other library's dependency. Library A and B both linked to CocoaAsyncSocket. and now I am going to use another framework. (Framework C) Since it is compiled, when I build my App, it shows...
Siu Chung Chan
1

votes
0

answer
96

Views

Access restrictions using cocoa pods and FeedKit?

I have an RSS Reader running on iOS(11.2.6) and watchOS(4.2) using cocoa pods and FeedKit: https://github.com/nmdias/FeedKit Result: The simulated version runs fine, RSS feeds get displayed on watch as expected. But the installed version fails to read valid RSS feeds on the real Apple watch. This is...
Beaker
1

votes
0

answer
317

Views

Using CocoaPods with Notification Content extensions

Is it possible to use Cocoa Pods with Notification Content extensions? If so, what do I need to do? I have used pods with keyboard extension where all I needed to do was to include: target 'host-app' do use_frameworks! pod 'Kingfisher', :git => 'https://github.com/onevcat/Kingfisher.git', :branch =>...
Milan Nosáľ
1

votes
0

answer
93

Views

How would I install Google Sign-In on a Swift macOS app?

When I try the normal way through Cocoapods: # Uncomment the next line to define a global platform for your project platform :osx, '10.13' target '1072 Scouting' do # Comment the next line if you're not using Swift and don't want to use dynamic frameworks use_frameworks! pod 'Google/SignIn' # Pods f...
atirit
1

votes
0

answer
82

Views

How to add a pod with a vendored_framework as a dependency to another pod?

The case (all names are not real): I have a Lib pod with a vendored_framework (an obj-c static library) Need to make another SDK pod (swift dynamic framework) Need to add the Lib as a dependency to SDK If I'm adding both Lib and SDK pods into my app's Podfile they are working great and both are avai...
norlin
1

votes
0

answer
96

Views

Refer the target's Preprocessor macro within a pod project

I have a project that has multiple targets. On each target's, I have added some pre-processor macros. It has multiple pods added to the workspace. Obviously, the target's preprocessor macro won't be visible to the pod projects. How can I get that done? 1) I tried using the post_install and tried to...
Sj.
1

votes
0

answer
49

Views

Getting “Module not found” when building 3rd party framework that depends on a CocoaPods module

Here is my situation: I am using CocoaPods but I can't use the 'use_frameworks!' directive as it is not compatible with ReactNative I need to include another team's SDK, distributed as a .framework This .framework depends on PureLayout, which is available through Pods Hence: I installed PureLayout t...
1

votes
0

answer
173

Views

Can not install cocoapods because of the password on Mac desktop

I have been trying to install using the command sudo gem install cocoapods on my desktop with OS. X High Sierra. After entering the command, it asks for the password. I enter an administrator password and it replies 'Sorry, try again'. Also, by the password, I see a sign of a key. Does it mean it...
Sergey_yaklichk
1

votes
0

answer
109

Views

DynamicBlurView pod get installed, without adding it to podfile.

here is my pod file for my project pod 'GoogleMaps', '1.13.2' pod 'Toast', '3.0' pod 'Fabric' pod 'Kingfisher', '~> 3.0' pod 'Crashlytics' pod 'EBForeNotification' pod 'SwiftDate', '~> 4.0' pod 'IQKeyboardManager' pod 'Alamofire' pod 'Gloss' pod 'RealmSwift' pod 'ObjectMapper+Realm' pod 'ObjectMapp...
nitkar
1

votes
1

answer
396

Views

JonkyKong's SideMenu 'No Such Module' error

I'm working on a fairly large iOS project using Swift 4.0 for which I require a side menu and JonkyKong's implementation of it seems ideal. I tried install it via cocoapods but I always get : 'No Such Module' on the Import SideMenu line of code. Cleaned the build using Option+Command+Shift+K Still n...
Elmaik

View additional questions