Questions tagged [bundler]

1

votes
2

answer
38

Views

Are there logs to see git commands from bundler?

I am using bundle install to install some Ruby gems from a mix of public and private git repos. The issue is that after one particular gem is installed through git, the local directory is polluted with that gem's source code. It's like the git repo has completely changed. Is there a way to log all t...
Rudolf Olah
0

votes
0

answer
4

Views

Problem installing bundler, Says it installs, but then doesn't actually install

I am setting up a new system. I'm using rbenv instead of rvm because rvm changes the definition of 'cd' and that's just evil. I've got the required version of ruby and rails (I think) installed, but bundler is causing problems: turlingdrome$ gem install bundler ERROR: While executing gem ... (Errn...
Brian Postow
1

votes
0

answer
5

Views

Can react-native bundler detect unused files?

Consider having a scenario, where we build our react-native App with release mode while having code like below: let img; if ( __DEV__ ) { img = require('./debug-image.png'); } else { img = require('./real-image.png'); } My question is, will both debug-image.png and real-image.png get bundled into th...
Top-Master
1

votes
2

answer
65

Views

Rails assets:precompile is using wrong bundler version

I recently updated my dockerized rails app (5.0 -> 5.2) and am now using Bundler 2. I've added RUN gem install bundler to my Dockerfile to ensure I have Bundler 2 installed. My RUN bundle install step runs fine, but when I get to the asset precompile step it seems to start using Bundler 1 again: Ste...
Deekor
1

votes
1

answer
27

Views

Bundler: Create Gem - Default Contact Info Source?

I followed this guide to build my first Ruby Gem: http://bundler.io/v1.12/guides/creating_gem.html Everything worked as expected, but I have one question: I noticed that Bundler auto-magically pulled my personal contact info from somewhere (I'm on a Mac) and used that to build the gem. An example o...
Pseudo
1

votes
0

answer
148

Views

Bundle Exec is Overwriting Environment Variables

I'm working in a phusion/passenger-ruby24 Docker image with my Rails application. My application is in //app and my gems are in //app_dependencies. When I execute bundle exec passenger start, the gems cannot be found (expected). However, when I set BUNDLE_PATH in the environment to //app_dependencie...
9TrSl9IAlaLfDmffagsw
1

votes
0

answer
60

Views

Heroku push rejected because gem checksum failed

I've been pushing updates to my app successfully all week. This morning I went to push another update (just some CSS changes) and suddenly I'm my pushes are being rejected because the checksums on numerous gems seem to be randomly failing. I say randomly because each time I've tried pushing, the fai...
Daniel Bonnell
1

votes
0

answer
36

Views

Configuration blocks in a Rails initializer don't work with local-path gems (?)

In my Rails app Gemfile, I have gem 'myfancygem', path: '/Users/matt/myfancygem' This works as you'd expect. I then added a configuration block feature to the gem, a la https://robots.thoughtbot.com/mygem-configure-block (and many others out there that are slight variants on this) I created an initi...
mepatterson
1

votes
0

answer
355

Views

Failed to build gem native extension - Ruby in Windows

I'm facing some problems at Windows 10 to install native extensions. This happened with many native gems. C:\Ruby23x64\bin>gem install websocket-driver Building native extensions. This could take a while... ERROR: Error installing websocket-driver: ERROR: Failed to build gem native extension. curre...
Thiago Lipovscek
1

votes
1

answer
1.4k

Views

Could not find rake-12.3.0 in any of the sources (Bundler::GemNotFound) - Bitnami Redmine Stack 3.3.1-0 on Ubuntu 16.04.2 LTS

I am using the Bitnami Redmine Stack 3.3.1-0 on Ubuntu 16.04.2 LTS. I recently installed a plugin (Issue Templates - http://www.redmine.org/plugins/redmine_issue_templates). In the process, I updated the gems using bundle install and bundle update. After performing this update, the Redmine websi...
User 392017
1

votes
1

answer
42

Views

Webpack 4 - Exposing variable to global context

I'm making a lib wrote in ES6 and will transpile it with Babel to the past version to avoid EcmaScript incompatibility. class MyLib { constructor(name) { this.name = name; } sayHello() { return `Hello ${this.name}`; } } // Would this work / is this the right way? // window.MyLib = MyLib module.expor...
juniorgarcia
1

votes
0

answer
37

Views

What is the proper way to add bundled files to the appcache manifest?

I've created a prototype single-page web app that uses bundling for my javascript and css resources. I want to have more control over how the client's browser caches the resources, so I'm attempting to implement a cache manifest. But I can't get the bundle urls in my manifest controller to match the...
Matt Spinks
1

votes
1

answer
21

Views

How can I use the Values gem with rails?

Gemfile: gem 'values' Also tried Gemfile: gem 'values', require: 'values' Gemfile.lock values (1.8.0) $ bundle install Using values 1.8.0 But $ rails console > Value NameError (uninitialized constant Value) > require 'values' LoadError (cannot load such file -- values) But if I just $ irb require 'v...
Samuel Danielson
1

votes
0

answer
428

Views

Bundle with docker-compose installs gems from scratch

I'm trying to cache bundle install on Docker build. I've tried recommendations from several blog posts and I ended up in something like this: Dockerfile: FROM ruby:2.5.0-alpine RUN apk update && apk add build-base postgresql-dev nodejs git tzdata ENV APP_HOME /panabus-api RUN mkdir $APP_HOME WORKDI...
hcarreras
1

votes
0

answer
75

Views

Does YARD have implicit dependencies?

In short, I have the following problem with my Ruby Gem project: rake doc runs locally without issue. (Ruby 2.3.1) rake doc errors out in the CI agent. (Ruby 2.5) bundle exec rake doc errors out locally with the same error. (Ruby 2.3.1) How can that be? Now for the details. The relevant part of my...
Raphael
1

votes
0

answer
94

Views

Loading command: install (LoadError) cannot load such file — socket

I bought new Macbook pro and moved all data from iMac to new Mackbook pro. then I tried to check the version of bundle with 'bundle -v', I got -bash: bundle: command not found them I tried 'gem install bundler', I got ERROR: Loading command: install (LoadError) cannot load such file -- socket ERRO...
riiinoj
1

votes
0

answer
398

Views

Running ruby project with systemd service cannot find gemfile

I would like to run a ruby project that uses bundle as a systemd service. The project is: https://github.com/jcs/bitwarden-ruby/ I installed ruby and bundler by running sudo apt-get install ruby-full and sudo gem install bundler In the project directory I run bundle install --deployment. In my syste...
Seb123
1

votes
0

answer
111

Views

'Bundler.require' requiring all gems?

Trying to figure out Ruby's Bundler library. My understanding is we can require only certain groups, but my setup seems to be loading gems specified in other groups as well. Gemfile source 'https://rubygems.org' # Specify your gem's dependencies in apple.gemspec gemspec group :production do gem 'ma...
Phani Anne
1

votes
0

answer
349

Views

How to update bundler version in dokku?

I use dokku 0.12.5 How to update bundler version gem bundle install doesn't work Update: [email protected]:~# dokku run app gem update bundler Updating installed gems Updating bundler Fetching: bundler-1.16.1.gem (100%) Successfully installed bundler-1.16.1 Parsing documentation for bundler-1.16.1 Installing...
Anton Ipatov
1

votes
1

answer
81

Views

Can't resolve dependencies: 'Bundler could not find compatible versions…'

Trying to upgrade Rails, set version to '5.0.0' in Gemfile. I don't understand why for example actionpack is not resolved after bundle update: Resolving dependencies.............................................................. Bundler could not find compatible versions for gem 'actionpack': In Gemf...
divideByZero
1

votes
1

answer
402

Views

bundle update not working correctly

This is the error I'm getting with bundle update: Bundler could not find compatible versions for gem 'railties': In Gemfile: coffee-rails (~> 4.1.0) was resolved to 4.1.0, which depends on railties (< 5.0, >= 4.0.0) rails (~> 5.2) was resolved to 5.2.0, which depends on railties (= 5.2.0) sass-rails...
digital king
1

votes
0

answer
148

Views

Running “gem install bundler” doesn't work, no error returned

When I run gem install bundler on my Windows 7 cmd, nothing happens and I get no error. The cmd just stays blank after the commnand. I have Ruby 2.4.4 installed on my machine. And I know there are already other posts here with the bundler not installing, but none are helping me as I am not getting a...
Johan
1

votes
0

answer
27

Views

Bundler could not find compatible versions - without contradictions

I am trying to bundle update a couple of gems and get back (amongst others) the following error from bundler (version 1.16.2): Bundler could not find compatible versions for gem 'activemodel': In Gemfile: rails (~> 4.0.13) was resolved to 4.0.13, which depends on activerecord (= 4.0.13) was resolved...
1

votes
2

answer
695

Views

Can't install nokogiri with bundle when build docker container in archlinux

Never was, and here again. ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-linux] Bundler version 1.16.2 Archlinux updated 4.17.4-1 x86_64 Pure ruby project I can install nokogiri with gem install nokogiri --no-rdoc --no-ri When I run bundle install --path=vendor inside my ruby project I need to a...
Dimitri
1

votes
0

answer
25

Views

How to use Bundler and Minifier in deployable web applications and installer projects

This is about how to use Visual Studio 2017 with both Bundler and Minifier and also the 'Visual Studio Installer Projects' extension. My web app has only one main page, so the tags are all there on one ASPX page, about 40 of them as there are 40 JS files. When I run bundler and minifier, I want one...
user2728841
1

votes
1

answer
138

Views

rubygems.org timeout issue from command line — SSL issue?

I haven't needed to use Linux in years, but now I am creating a linux machine so I can run Ruby on Rails. I am using Ubuntu 18.04. I thought I had everything loaded up and was trying to create my first Rails project but I got an error during: run bundle install --local Traceback (most recent call...
cmdoc
1

votes
0

answer
203

Views

Why “bundle install” needs “sudo” for this “gem env”?

Relevant output of Jenkins pipeline: + gem env RubyGems Environment: - RUBYGEMS VERSION: 2.6.14 - RUBY VERSION: 2.4.2 (2017-09-14 patchlevel 198) [x86_64-darwin16] - INSTALLATION DIRECTORY: /Users/jenkins/.rbenv/shims - USER INSTALLATION DIRECTORY: /Users/jenkins/.gem/ruby/2.4.0 - RUBY EXECUTABLE: /...
an0
1

votes
0

answer
69

Views

another error faced when installing snorby on linux

When installing snorby, I need to use this line: sudo bundle exec rake snorby:setup When executing this, a problem occurred: rake aborted! There was an error while trying to load the gem 'delayed_job'. Gem Load Error is: undefined method `yaml_as' for Module:Class Did you mean? yaml_tag (PS: It is...
Leo Wu
1

votes
0

answer
112

Views

Bundle Install Json Error

My ruby environment is pretty much setup. I can retrieve my Gherkins syntax via command line and run simple ruby web tests. But I need some other gems to complete the environment. All I need to do is get bundle install working, but can't figure out why it's not installing. I've updated my gems as we...
Martin Marino
1

votes
1

answer
38

Views

Ruby microservices - how to restart / respawn in production

I'm currently in the process of moving some Rails functionality out into some microservices, I shan't bore you with the reasons for this, suffice to say we're happy with the decision and our architecture choices. At the moment it is not particularly complicated, a handful of standalone scripts runni...
Stewart
1

votes
0

answer
45

Views

Ruby bundle console is not loading aws shared credentials from ~/.aws/credentials

How can I load aws credentials to ruby if I use bundler console. Scenario: I have the following code in samplefile.rb and aws credentials in ~/.aws/credentials require 'aws-sdk-core' require 'aws-sdk-s3' require 'json' class Publisher def listBuckets profile_name = 'AWSConsumer' region = 'us-east...
Santhosh Nagulanchi
1

votes
1

answer
522

Views

How to change the version a gemfile.lock is bundled with

I had two versions of bundler installed locally 1.15.2 and 1.16.1. I had pushed my code and soon realized that the gemfile.lock BUNDLED WITH, updated the version to 1.16.1 and that is not what we want. I then removed 1.16.1 locally and now my default is 1.15.2 which is exactly what I want and ran b...
Chris
1

votes
0

answer
154

Views

Why Redmine web application encountered an internal error when Passenger server tried to start it?

I intended to run Redmine web application on CentOS 7.5 server running Apache and Phusion passenger. After installing and configuring the whole thing, when I accessed http:// in the web browser, I got a message that said Error starting web application After I enabled PassengerFriendlyErrorPages in...
Amroz
1

votes
0

answer
33

Views

Why am I getting this bundle error on rails?

This is the error on rails when I try running bundle command bundle exec rake -P rake aborted! LoadError: cannot load such file -- bootsnap/setup This is my Gem file source 'https://rubygems.org' gem 'rails', '5.1.6' gem 'bcrypt', '3.1.12' gem 'faker',...
Kevin
1

votes
0

answer
45

Views

Bunder is installing with rubygems dependency not version in gem directory

I'm using rbenv to manage my Rubies. Heroku seems to only (or at least prefer) Bundler v1.15.2 according to their Ruby Support docs. So I: $ bundle exec gem install bundler -v 1.15.2 and that's the only version of Bundler in Ruby 2.4.4's gem directory. However when I bundle install or bundle update...
Meltemi
1

votes
1

answer
41

Views

Bundler not finding current ActiveModel when updating Rails

Trying to update a Rails 4.2.9 app to Rails 5.2.1. Changed the Gemfile: gem 'rails', '5.2.1' But Bundler appears to not be able to find an appropriate version of ActiveModel (which is not specifically called out anywhere in the Gemfile). I have updated the gems mentioned below to their most current...
Meltemi
1

votes
1

answer
66

Views

How to require module only if exist. React native

Example: let tmp; try { tmp = require('module-name'); } catch(e) { return; } I get error (react native Metro Bundler): error: bundling failed: Error: Unable to resolve module `module-name` from ... How to require 'module-name' only if exist?
MatthewP
1

votes
1

answer
30

Views

Passenger cannot load rbenv managed versions

A server has two users. deploy has sudo privileges, guest does not. guest has an application that is migrating ruby versions (from 2.3.4 to 2.4.5). Initially, after guest installs version 2.4.5 passenger cannot start because it does not find this version of ruby. deploy had to install it. However,...
Jerome
1

votes
0

answer
57

Views

Cannot run bundle install due to dependencies

I recently installed RubyMine and I believe at some point during install it screwed up my environment. My app is relatively old and I am running Rails -v 4.2.2 and Ruby -v 2.2.3. When I run bundle install it gets pretty far and fails at: The latest bundler is 2.0.1, but you are currently running 1....
Jeremy Thomas
1

votes
0

answer
54

Views

Git repository without refs directory but with packed-refs file is invalid

Somehow, I got into a state where I had some git repos that didn't have a refs directory, but did have a packed-refs file. When trying to use those repos, git would immediately error out with: fatal: not a git repository (or any of the parent directories): .git All I had to do was make an empty refs...
onlynone

View additional questions