Questions tagged [buildozer]

1

votes
1

answer
426

Views

Kivy: Buildozer.spec file is not completed

I prepared kivy buildozer for using. For installation I used instructions here, process for python 3. After step 3, buildozer.spec file wasn't completed and checked lines (step 4) had next content: requirements = kivy #android.ndk_path = Message about installation after buildozer android debug depl...
jasan
1

votes
1

answer
272

Views

Error during using buildozer for kivy packing

For packining I used instrumentalities which are recommended in kivy manual I use for kivy packing virtual machine from https://kivy.org/#download (Oracle virtual box and settings of virtual machine) For buildozer installating I used process https://github.com/kivy/buildozer, for Python 3. I manua...
jasan
1

votes
0

answer
99

Views

Kivy buildozer debug error :No module named kivy

I'm trying to build a simple kivy app with buildozer and python2 , but for some reason inside this build no module 'kivy'. And Some logs from buildozer : [INFO]: STDOUT: Using distutils Environ change use_sdl2 -> True Cython check avoided. Traceback (most recent call last): File 'setup.py'...
Wade.ZeaK
1

votes
1

answer
1.2k

Views

buildozer(kivy,python) failed in copying generated apk to the home dir on docker virtual machine

I tried to run buildozer in docker virtual machine to generate andorid app package(.apk). After tried and filed sometimes, his Dockerfile(https://github.com/jedie/kivy-buildozer-docker) was determined to use to make my environment for my purpose. However, in almost finished building, the error occur...
user2058374
1

votes
0

answer
119

Views

Specifying FFMPEG in the requirements section of 'buildozer.spec' causing [libavformat/network.o] Error 1

My question relates to how to mitigate an ffmpeg requirement listed in a buildozer.spec that is causing compile errors using buildozer. GOAL: Using buildozer to ensure FFMPEG can be embedded within a small Kivy app so i can utilise youtube_dl functionality on my android phone. THE ISSUE: Specifying...
GJ78
1

votes
1

answer
273

Views

Kivy Buildozer vm ant build failing

I am trying to build the Hello World Kivy app on the Buildozer vm. Everything runs fine until Ant tries to compile the files. I have attached the full error log and buildozer.spec [email protected]:~/Documents/TestKivy/src$ buildozer android_new debug # Check configuration tokens # Ensure build layout # C...
mcmahonS9
1

votes
0

answer
163

Views

Buildozer failed while compiling into APK

Here is the app: #!/usr/bin/env python2 # -*- coding: utf-8 -*- ''' Created on Sat Feb 3 23:11:38 2018 @author: djaber ''' from kivy.app import App from kivy.uix.scatter import Scatter #from kivy.uix.button import Button from kivy.uix.label import Label from kivy.uix.floatlayout import FloatLayout...
Djaber Berrian
1

votes
0

answer
58

Views

Buildozer adding my packages

I developed an app in python3.5.2 gui work by using kivy and it's working fine in pc but not in android I have my package (name=PassStorage) consist 3 mudules (name=accounts.py,data.py,keyandnick.py) that are connected to each other by compositions and in main.py i am importing these mudules from Pa...
user378625
1

votes
0

answer
211

Views

How to change kivy builldozer app icon and splashscreen ? ( python 2.7, kivy )

all i want to know is how to change the default buildozer icon and splash screen. assuming that my icon file is called 'icon.png' and my splashscreen is 'splash.png' and that they are both located in the same directory as the main.py file and the buildozer file, what do i replace with the following...
Hussam Al-hassan
1

votes
0

answer
335

Views

How to use nltk in android using Kivy and buildozer

I need to test NLTK program in android with Kivy. But app crashes when I open the app. Program has no errors. I tried modifying the buildozer.spec file(added nltk in kivy requirements) but it didn't workout. How to make it work? Here is the 'app' section of buildozer.spec file [app] # (str) Title o...
swordtail
1

votes
0

answer
85

Views

Buildozer failed to Unpacking pyjnius for armeabi-v7a

I am new to kivy and buildozer. I have been trying to start off by trying to debug and deploy a sample code on my phone. But I have been getting this error consistently.I have checked and found the zip files in the directory. Please help, this is the error below: Traceback (most recent call last):...
A . Ngwarati
1

votes
0

answer
225

Views

SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure [Kivy]

In my app I am fetching JSON from various sites but I get handshake failure on a particular site. My app works fine on windows but fails on android. here is log snipet which I have doubt on. I guess there is some certificate issue. I/python (16801): /data/data/org.test.coinswatch/files/app/lib/pyt...
NGB
1

votes
1

answer
708

Views

Can't build Kivy project with buildozer and python3crystax

Sorry for possible stupid question, but today I spent ~5 hours trying to build simple apk with Python3, Buildozer and Crystax NDK. I used Buildozer VM, downloaded Crystax ndk 10.3.2, created buildozer.spec as follow on github instruction https://github.com/kivy/buildozer . My buildozer.spec: title =...
l0ngint
1

votes
1

answer
40

Views

Why kivy giving diffrent result after apk packaging?

This is my Custom Widget:- : size_hint: (1, None) height: sp(100) canvas.before: Color: rgba: 1, 1, 1, .65 Rectangle: pos: self.pos size: self.size canvas: Color: rgba: 1, 1, 1, 1 Rectangle: size: sp(30), sp(30) pos: self.right-sp(50), self.center_y source: root.status Label: id: first_letter text:...
user378625
1

votes
0

answer
93

Views

Buildozer compilation with firebase-admin and google-cloud-firestore: “No module named google.auth”

I'm trying to use Firestore in Kivy app and compile with Buildozer. The app works perfectly on Windows. In addition to kivy import, I imported: pip install firebase-admin pip install google-cloud-firestore In the VM of kivy, I put: requirements = kivy, firebase-admin, google-cloud-firestore The buil...
joaolucaslr
1

votes
0

answer
40

Views

Buildozer Error

I tried to create a Kivy APK using Buildozer but I keep receiving the same error no matter what I do. I am using Ubuntu. Here is the Error: [INFO]: STDOUT (last 20 lines of 172): jnius/jnius.c:47655:20: warning: format '%zd' expects argument of type 'signed size_t', but argument 4 has type 'long...
PerrytheKeypad
1

votes
0

answer
157

Views

App crash with kivy and bs4

I build the apk in the kivy VM and after building, when I open the app on android, crashed I get first this error: ImportError: cannot import name _htmlparser I search on the internet i and I found this solution: Buildozer compiles apk, but it crashes on android But after do this, crash again but w...
Johnlper
1

votes
0

answer
80

Views

Error using CrystaX within Buildozer building an APK

Currently using the Kivy/Buildozer VM in order to convert a Python Script into an APK, however everytime I use 'buildozer android debug' I end up with this error; [INFO]: # Prebuilding recipes [INFO]: Prebuilding hostpython3crystax for armeabi-v7a [INFO]: hostpython3crystax has no prebuild...
Rian Hunter
1

votes
0

answer
103

Views

buildozer download android sdk without api

I run buildozer android debug and I see this: # Read available permissions from api-versions.xml # Check application requirements # Check garden requirements # Compile platform # Run '/usr/bin/python3 -m pythonforandroid.toolchain create --dist_name=myapp --bootstrap=sdl2 --requirements=kivy --arch...
hamid k
1

votes
0

answer
181

Views

configure: error: C compiler cannot create executables - Buildozer kivy to android debuging

ENTERING MY PROBLEM (they can skip it) Hello, I am trying to compile apk application, but I always have many problems due to lack of libraries and applications that my system does not bring and that are not mentioned in the buildozer and kivy requirements. I am stuck in this error after installing a...
TraXonN
1

votes
0

answer
271

Views

Problems compiling APK with buildozer for Android (NDK and SDK)

I am trying to generate an APK using buildozer. The following shows the specs in my buildozer.spec file and my computer specifications: python 2.7, Buildozer 0.35 kivy 1.10.1 buildozer.spec file # (int) Android API to use android.api = 28 # (int) Minimum API required android.minapi = 24 # (int) Andr...
Anas Musah
1

votes
0

answer
158

Views

gradlew assembleDebug failing when building apk with buildozer

I am trying to build a signed apk using buildozer on a virtual machine which is running on windows 10 but I am getting this error: [INFO]: Selecting java build tool: [INFO]: Detected highest available build tools version to be 28.0.3 [INFO]: Building with gradle, as gradle executable is...
SABIRASMASY
1

votes
0

answer
85

Views

Android .apk with kivy + matplotlib

First, I am sorry if this is a duplicate question but I have spent many hours before writing here looking for an answer and could not find any (that would work at least). I want to (ideally) compile a python (3.6/7) script into an android app. I need to use external libraries in my code, namely matp...
Arce11
1

votes
0

answer
41

Views

how can I solve this Buildozer debugging given ValueError?

I have been trying to get my kivy app to debug for android using the kivy buildozer VM. I keep running into < # Run '/usr/bin/python -m pip install -q --user \'appdirs\' \'colorama>=0.3.3\' \'jinja2\' \'six\' \'enum34; python_version=1.10; sys_platform!='nt'\'' # Cwd None Exception: Traceback (mos...
Ryaniii
1

votes
0

answer
42

Views

Send email script works on Win, but not on Andorid

This script sends mail when is ran on Windows and Linux, but not on Andorid. What is the issue? My app requirements in p-4-a are python3, kivy, openssl. Permission is INTERNET. App crashes when I run method below. def send_report(self): server = smtplib.SMTP('smtp.gmail.com', 587) server.ehlo() serv...
raja_rasta
1

votes
0

answer
32

Views

I am getting an error while using the buildozer

I am trying to build an apk android with buildozer and I came across an error. I've followed the instructions in the Kivy documentation page but still getting this error. Any advice is must appreciated. Thanks.enter image description here [email protected]:~/Downloads$ buildozer android debug # C...
Sean
0

votes
0

answer
14

Views

There is no cv2 module in apk

Good afternoon, there is a small application written using python, kivy and opencv. The buildozer builds without errors, but when I launch the application on the phone it crashes with the following error: 04-12 18:44:54.848 5697 5739 I python : File '/home/max/desktop/finish/.buildozer/androi...
Slark
1

votes
1

answer
589

Views

Python 2.7 urllib.urlretrieve unknown url type https

I previously ran into this error and after fixing it, I ran into this: I/python ( 7569): Traceback (most recent call last): I/python ( 7569): File '/home/cristi/Desktop/AplicatieMinister/.buildozer/android/app/main.py', line 102, in I/python ( 7569): File '/home/cristi/Desktop/AplicatieMi...
1

votes
1

answer
263

Views

Buildozer can't load CSV module after removing it from blacklist

I am building app for android using python, kivy and Buildozer. I am including CSV module in code. CSV module is blacklisted by default in Buildozer in blacklist.txt I removed it from all blacklist.txt files. After that if I try 'buildozer android debug' this error occurs: # Command failed: pip in...
Tibor
1

votes
2

answer
1.2k

Views

Kivy on Android not working

I'm testing my first app on Android written in Kivy I've followed the tutorial here I've copied the app to my android device, but when I run it, it just stops I've used: buildozer android logcat and the relevant lines of output seem to be: I/python (32075): ['/data/data/org.test.bfgapp/files/lib/p...
Psionman
1

votes
1

answer
235

Views

How to control which kivy version buildozer deploys on android?

Which kivy version does buildozer deploy on android and is it possible to control this?
s0kol
1

votes
1

answer
430

Views

Buildozer - requirement pysftp

I'm able to use pysftp on kivy, but I can't package my app using this requirement. Using buildozer, in the message says I'm using pip 8.1.1 and there is another version, 8.1.2. But I checked my version and my one already is 8.1.2. And, of course, I can install pysftp using pip install pysftp. My log...
awulll
1

votes
1

answer
484

Views

Subprocess with android app

I have made an application with Python and Kivy. Générated an apk file with buildozer. In this application I generate *.xlsx files. I want to add a button to open directly the xlsx file with the google Sheets application. But I don't know how I can do this. I know the suprocess system on python bu...
Serial86
1

votes
1

answer
209

Views

Buildozer Android Kivy Fail on importing requirement

I have tried to import a python module on a kivy app for android, anyway whenever i add a requirement in buildozer.spec the build fails out putting this: # Run 'pip install --download-cache=/home/arctia/.buildozer/cache --target=/home/arctia/Scrivania/Kivy/Programs/Domo_Skills/.buildozer/applibs ope...
Scias Bof IV
1

votes
1

answer
338

Views

netifaces import error on android in kivy buildozer

I Have import netifaces in buildozer requirments. But After buillding the app. At the runtime of app, I'm having a problem importing netifaces on android in kivy app. Output is below. Whats this error trying to say. Its gives some error like: [Errno 13] Permission denied: '/data/.python-eggs' the fo...
Nikesh Nayak
0

votes
0

answer
4

Views

Kivy Plyer Vibrate cCrash on Android (logs included)

Any help would be appreciated. I have an app that works perfectly in Ubuntu and Pydroid, but crashes after packaged when it needs to activate the Vibrate code from plyer. The log indicates some jnius missing params, but I am not an expert. Spec file is also included. The python code used for vibrat...
Archaeus
1

votes
1

answer
114

Views

Buildozer Error With Json

pip install json fails on ubuntu and gives errors like this. I am trying buildozer android debug on my Ubuntu machine and I have a dependency json. The problem is, buildozer is internally trying to install json and it is giving the exact same error: RuntimeError: Package 'json' must not be downloade...
Abhipso Ghosh
1

votes
1

answer
278

Views

How to use SQLAlchemy with buildozer?

Recently buildozer has compiled a simple 'hello world' program. But i want to use SQLAlchemy in main.py file. The file contains: # -*- coding: utf-8 -*- import kivy kivy.require('1.10.0') from kivy.app import App from kivy.uix.button import Button from sqlalchemy import create_engine from kivy.uix....
dilde olupbiten
1

votes
1

answer
100

Views

App works well on Windows in Python2 & Python3, but receiving Error : failed to import android, and Button unresponsive

This is an app written in python 2.7 using kivy and numpy modules. I have installed buildozer by following steps in this link : https://github.com/kivy/buildozer , i did not do sudo pip install https://github.com/kivy/buildozer/archive/master.zip. After deploying the app on android buildozer android...
Arief Anbiya
1

votes
1

answer
621

Views

Buildozer fail with numpy requirement

I'm trying to make a app that uses numpy, but when I compile with buildozer I get a error (apparently download error). When I compile without numpy, it's fine. Obs.: I was using a VirtualBox Ubuntu 16.04 (configured for myself), then I thought that I was doing anything wrong, then I download the ki...
André Ginklings

View additional questions