Questions tagged [android-studio-3.2]

1

votes
0

answer
25

Views

Android Studio 3.2 Canary 12/14/15/16 has no Github integration

The Android Studio 3.2 Canary version 12/14/15/16 doesn't have github integration, so I can't clone it from it, and when I try to pull/push on an already cloned repository, it keeps me asking for credentials everytime, and after 3 times trying to logging in, it gives me an unauthorized error. Alrea...
julioribeiro
1

votes
0

answer
201

Views

Cannot find Jetpack in Android studio 3.2 Beta 2

I've been using Android studio 3.2 canary 15 (Preview) for a while now and it was working fine with jetpack (Really slow, but fine) The problem is every time I try to update (Tried beta 1 and 2), I cannot see the jetpack package (When I create a new project, the 'Fragment & Activity+ ViewModel optio...
Mario Mouris
1

votes
1

answer
279

Views

Only “Fragment + View Model” in Android Studio JetPack version 3.2 Preview Beta 5

I am checking lots of tutorials on Youtube and Google and all are referring to snapshots where the default activity to be selected for JetPack is ' Activity & Fragment + ViewModel'. However when i create a new activity i see the following screen: New Activity Creation Screen in Android Studio 3.2 Be...
Ankur Singh
1

votes
1

answer
352

Views

After Android studio upgrade to 3.2 error appears startup failed: initialization script '/tmp/ijinit.gradle'

After upgrading from 3.1 to 3.2 Gradle build is failed with error Cause: startup failed: initialization script '/tmp/ijinit.gradle': 3: unable to resolve class org.jetbrains.plugins.gradle.tooling.internal.ExtraModelBuilder @ line 3, column 1. import org.jetbrains.plugins.gradle.tooling.internal.Ext...
Tigran Babajanyan
1

votes
0

answer
27

Views

Setting buildType attribute for specific flavour at android studio

Is it possible to change a buildType attribute like debuggable for a specific build flavor? I am trying setting it up using applicationVariants like this: applicationVariants.all { variant -> if (variant.name == 'flavorQuaRelease') { variant.buildType.debuggable = true } } but got this error: Cannot...
ByteArtisan
1

votes
1

answer
84

Views

Unable to open some activities java files

Today I'm not able to open some java files in Android Studio. They seems to contain R classes from Android Studio but if I open them from another editor they are opened right. Here's a screeshot: Help. The app debug with no errors and works
Davide Bicego
1

votes
2

answer
710

Views

Could not find builder.jar (com.android.tools.build:builder:3.0.1)

I update my android studio to 3.2.1 now when I start a new project everything is OK. but when I open the last project I have an error : Could not find builder.jar (com.android.tools.build:builder:3.0.1). Searched in the following locations: https://dl.google.com/dl/android/maven2/com/android/tools...
mohamadreza ch
1

votes
0

answer
150

Views

Error during Sync: Broken pipe issue in Android Studio on Mac OS

Suddenly having this issue in Android Studio. Tried both in Android Studio 3.2 and 3.3 version the same issue. Application running properly in Android emulator but not working for real Android device. Showing this error when trying to run the application: Error during Sync: Broken pipe Session 'app'...
0xalihn
1

votes
0

answer
158

Views

Android Studio 3.2.1 menu tools missing item Android

I have installed Android 3.2.1 from https://developer.android.com/studio/. I have SDK location in 'C:\Users\myUser\AppData\Local\Android\Sdk' with 'SDK Platforms' installed 'Android 9.0(Pie)'. enter image description here enter image description here I have my JAVA_HOME variable with JDK 1.8. When I...
user1361416
1

votes
0

answer
151

Views

Android Studio 3.2.1 design view is broken

The problem I've started to notice that my Android Studio is showing some weird glitches lately when I'm working with layout files. It started by randomly breaking AS GUI, which was solved by a restart. But since today, every time I try to open the design view, it breaks. The picture below will sh...
Mauker
1

votes
1

answer
42

Views

Custom Button style is appearing in preview but not on device API 27

I created a custom button, it is appearing in the preview, but not on my phone. The minimum API is 17 and my phone's API is 27. //custom button true -3dp @color/Red viewStart //xml
EliodeBeirut
1

votes
2

answer
39

Views

Android Studio Ui test gives an error when enabling Java 8

I tried on Android Studio 3.2.1 and Android Studio 3.4 If I enable Java 8 in gradle file and run espresso test, I receive this error: java.lang.RuntimeExceptionCause: java.lang.RuntimeException After many trials, I found that removing Java8 support from gradle files fixes the issue. But java 8 is im...
Hisham Bakr
1

votes
0

answer
23

Views

Android Studio : Connection Refused (Connection refused)

I've just configured Android Studio 3.2 into my Ubuntu 16.04. Now I'm trying to create new project, it tries to download gradle then it sync & at the end it fails & shows me this errors with the top message in red fonts : Connection Refused (Connection refused) org.gradle.api.ProjectConfigurationExc...
Android Developer
1

votes
1

answer
0

Views

Cannot reinstall a signed APK generated on Android Studio 3.2

I have successfully build a signed APK and installed it on my device. Then, I uninstall the app (Setting -> Application Manager -> MyApp -> Uninstall) and try to install it again. The second time I try to install it I get 'App not installed' with the following stack trace: 12-03 14:37:12.785 834-859...
Diogo Melo
1

votes
2

answer
0

Views

Files present in .gitignore always get added to git after building Android Project in Android Studio 3.3.2

I have updated android studio from 3.0.0 to 3.3.2. Everytime I build project files like .idea/caches/build_file_checksums.ser and .idea/caches/gradle_models.ser get added to git. This files are already present in .gitignore.This is my Project level .gitignore file *.iml .gradle /local.properties /....
Satyam
0

votes
2

answer
16

Views

Gradle project sync failed. basic functionality (e.g. editing, deugging )will not work propery

gradle sync failed when the firebase cloud messaging Dependency is applied. i have tried all the version of FCM in app like 17.0.0, 17.3.2, 15.0.0, 16.0.1 etc enter image description hereenter image description here enter image description here
rajat
0

votes
0

answer
4

Views

AAPT2 aapt2-3.2.1-4818971-windows Daemon #0 - Error Often

I need you help and your support Now, I'm on procces to build my project mobile apps with android studio Why the R Layout always error once open the project and if try new project and R Layout can not be generated R layout. Could help me please to solve this problem Android resource compilation fail...
Syah Reza
2

votes
2

answer
38

Views

How to get rid of the warning “cannot resolve symbole 'id/andr'” for ExpandableListView"

An app uses ExpandableListActivity, and the usage of ExpandableListView is standard based on the document: Android Studio 3.2 has the following warning: How can I get rid of the warning?
Hong
0

votes
0

answer
3

Views

How to diagnose Android Studio crashes without any warning?

Android Studio started to crash frequently after I upgraded my PC from Intel i5-3570K to AMD Ryzen 7 2700. It is is the only program that crashes on this PC. I run a large number of other applications on this PC (Visual Studio, Chrome, Opera, Word, Excel, Thunderbird, Outlook...). None of them cr...
Hong
3

votes
6

answer
303

Views

How to solve NonNull annotation after Android Studio 3.2?

After updating to Android Studio 3.2, I've been getting a 'Probable bugs' from lint saying: 'Not annotated method overrides method annotated with @NonNull'. I had no issue before updating to Android Studio 3.2, how do I solve this? @NonNull @Override public View getView(int position, @Nullable View...
Karl Ghosn
6

votes
2

answer
1.3k

Views

Gradle error when Update to Android studio 3.2

I updated my Android Studio version to 3.2. Now I am facing following error for my project - com.novoda.gradle.release.AndroidLibrary$LibraryUsage.getDependencyConstraints()Ljava/util/Set; Currently I am using gradle version 4.6. Issue link https://github.com/novoda/bintray-release/issues/177 says t...
nikhil bansal
3

votes
1

answer
368

Views

Android Studio 3.2 Beta 1 !zip.isFile Error

I've recently updated Android Studio and my build.gradle version to 3.2.0-beta01. When I build and run the project !zip.isFile() error occurs with information below: Caused by: java.lang.IllegalArgumentException: java.lang.IllegalArgumentException: !zip.isFile() org.gradle.api.tasks.TaskExecutionExc...
Aydinozkan
2

votes
1

answer
306

Views

Could not set unknown property 'enableR8' for object of type com.android.build.gradle.internal.dsl.BaseAppModuleExtension

i add this code in android studio 3.2; android.enableR8 = true Could not set unknown property 'enableR8' for object of type com.android.build.gradle.internal.dsl.BaseAppModuleExtension What does it mean ?
Alireza
2

votes
2

answer
485

Views

ResourceType For resource entry index is beyond type entryCount

I use Android Studio 3.2. When I clean/rebuild project I see these warnings in build tool window: W/ResourceType( 6139): For resource 0x0101053d, entry index(1341) is beyond type entryCount(1155) W/ResourceType( 6139): For resource 0x0101053e, entry index(1342) is beyond type entryCount(1155) W/Reso...
hasanghaforian
1

votes
1

answer
9

Views

Trying to read a .csv file from downloads folder of internal storage android studio

I am trying to read contents of .csv file which is in my downloads folder of internal storage of my phone. My code looks like this. protected void onCreate(Bundle savedInstanceState) { super.onCreate(savedInstanceState); setContentView(R.layout.activity_main); browse = (Button) findViewById(R.id.b...
Vihar Bhatt
4

votes
1

answer
746

Views

Navigation Preview unavailable in Android Studio 3.2 Preview

I am interested to try the Navigation graph showed in the Android Studio. But I got the preview unavailable after I import the google sample I used the Android Studio 3.2 Preview Canary 16 Update on 10/6/2018: Even I rebuild the project it doesn't work. But if added new screen, it showed the new one...
Long Ranger
6

votes
7

answer
2.7k

Views

Google Play Instant Development SDK Update Fails

Android Studio 3.2 RC3 keeps asking me to update the Google Play Instant Development SDK (from 1.3.0 to 1.4.0), but it always fails the update with this message: Failed packages: - Google Play Instant Development SDK (extras;google;instantapps) How can I fix this?
mFeinstein
6

votes
2

answer
426

Views

kotlin-android error when using Android Studio 3.2 Canary 17

Just updated to Android Studio 3.2 Canary 17 and now getting following error: A problem occurred configuring project ':some_module`. 'kotlin-android' expects one of the Android Gradle plugins to be applied to the project: * android * com.android.application * android-library * com.android.library *...
John O'Reilly
3

votes
1

answer
153

Views

Android Studio 3.2 Canary 14 Github integration

I just updated to the new 3.2 Canary build of Android Studio and everything seems to work fine, except for Github integration. When I try to push or pull through the UI, I get the following error: Invocation failed Unexpected Response from Server: Unauthorized java.lang.RuntimeException: Invocation...
Kelevandos
3

votes
0

answer
85

Views

difference between the deprecated Java SDK and current Kotlin SDK for using Rocket chat in Android app

what is the difference between the deprecated Java SDK and current Kotlin SDK for using Rocket chat in Android app? If we use the Java SDK now, which are the functionalities that are unavailable or has problems? I want to use it for an android project which is in Java. what problems will I face if I...
3

votes
1

answer
220

Views

Some Conflicts were found in the installation area - Android Studio - cacerts error

I am on Android Studio 3.0.1 and wanted to upgrade it to latest one.But I am getting this attached error due to jre/jre/lib/security/cacerts . Does any one have any idea how to fix it. It says patch cannot be applied.
Raulp
3

votes
0

answer
68

Views

How to suppress Android D8 build warnings

I recently upgraded to Android Studio 3.2 which enables D8 Desugaring by default. In the build logs, i see lot of warnings related to D8. Could any one guide me on how to suppress these warnings? D8: Interface java.lang.instrument.ClassFileTransformer not found. It's needed to make sure desugari ng...
Firewall_Sudhan
3

votes
1

answer
184

Views

Installation failed with message Failed to commit install session

Getting an error message while trying to run an apk through android studio 3.4 canary 1. Gradle plugin version com.android.tools.build:gradle:3.4.0-alpha01 Installation failed with message Failed to commit install session 526049657 with command cmd package install-commit 526049657.. It is possible...
Jude Fernandes
3

votes
2

answer
166

Views

Gradle Sync Failed: Setup Project Failed: Null

long time I didn't have an issue like that. Possibly it's related to testing the Preview build on that project. Currently on stable Android Studio Version 3.2.1 I always get this strange error: What I already did: Invalidate Caches and Restart Clean Build Test Terminal Build (everything works) Impor...
cV2
3

votes
1

answer
204

Views

Program type already present: android.support.v7.appcompat.R

I'm facing issue while try to make bundle with following gradle and dependencies project gradle: buildscript { ext.kotlin_version = '1.2.51' repositories { jcenter() maven { url 'https://maven.google.com/' name 'Google' } } dependencies { classpath 'com.android.tools.build:gradle:3.2.0-beta05' //...
Ashish Singh
3

votes
2

answer
515

Views

Could not find com.android.support:appcompat-v7:28.0.3

I can't solve this problem, please help me! I've got the following error: Could not find com.android.support:appcompat-v7:28.0.3. Searched in the following locations: file:/C:/invincible/extras/m2repository/com/android/support/appcompat-v7/28.0.3/appcompat-v7-28.0.3.pom file:/C:/invincible/extras/m2...
Амина К.
3

votes
2

answer
185

Views

Building App Bundle Proguard Error

When i try to build app bundle with android studio 3.2 canary 17 i get the following error message. i have no idea what is missing angular bracket went through all of my proguard files and everything seems fine and is working in older version of android studio. gradle build tools is com.android.tool...
3

votes
1

answer
212

Views

Build failed unknown property 'packagingOptions'

After Android Studio upgrade to 3.2 version I can't make the build. FAILURE: Build failed with an exception. What went wrong: A problem occurred configuring project ':app'. Could not get unknown property 'packagingOptions' for task ':app:packageRelease' of type com.android.build.gradle.tasks.Package...
appersiano
4

votes
1

answer
325

Views

Could not resolve all files for configuration ':app:androidApis'.

Could not resolve all files for configuration ':app:androidApis'. Failed to transform file 'android.jar' to match attributes {artifactType=android-mockable-jar, returnDefaultValues=false} using transform MockableJarTransform
shaohua
45

votes
5

answer
7.5k

Views

Failed to resolve variable '${animal.sniffer.version}' when migrate to AndroidX

I'm using Android Studio 3.2 Beta5 to migrate my project to AndroidX. When I rebuild my app I got these errors: ERROR: [TAG] Failed to resolve variable '${animal.sniffer.version}' ERROR: [TAG] Failed to resolve variable '${junit.version}' Full clean & rebuild did not work! Anyone know how to fix thi...
nhoxbypass

View additional questions