URI scheme missing from Branch.io $deeplink_path

Refresh

April 2019

Views

219 time

1

Our Branch.io deep links only open the app but don't navigate to the correct view, since we rely on a pod DeepLinkKit which expects the incoming $deeplink_path to include a URI scheme (i.e. https:// or appName://)

The Branch Debugging Tool shows that $deeplink_path and $ios_deeplink_path both contain the correct URL, but without the needed URI scheme (appname.com instead of https://appname.com).

I tested a Branch URL with a custom $deeplink_path that included the URI scheme and it worked to open the correct app view. Is there anyway to programmatically ensure each Branch link contains a URI scheme in the $deeplink_path?

1 answers

0

This is Vatsal, from Branch.io.

When you set $deeplink_path or $android_deeplink_path you only need to specify the path value such as "category/bags". Once you click the Branch link and open the browser, we will generate the URI scheme which will look like urischeme://category/bags?link_click_id= to open the app.

But, in the link data within initSession() method, you'll get $deeplink_path as "category/bags" only. There will be no URI scheme appended.

If you are using Android App links or Apple Universal links to open the app, then we will not fire any URI scheme and you will still get $deeplink_path as "category/bags" as the deep link data.

The URL $deeplink_path you are getting is from the App Indexing tags that you have set in the web URL which is being used as the $desktop_url. Branch scrapes the web URL and fetches the app indexing tags you have and sets them as the $deeplink_path.

If you have more doubts or if you wish to disable this auto-scraping, please write us at [email protected] and we will take this conversation forward.

Best