Java is Crashing When i open intelij idea

Refresh

April 2019

Views

310 time

5

It often crashes when I open Intellij Idea.

I have tried different Intellij Idea versions (2019.1, 2018.3).

I installed Oracle JDK (Java SE Development Kit 8u201).

My Os : macOs Mojave.

This is the one part of the crash logs : (it is too long to share all logs here. to see all logs : here paste bin )

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x000000011080b574, pid=4503, tid=0x000000000000a603
#
# JRE version: OpenJDK Runtime Environment (8.0_152-b28) (build 1.8.0_152-release-1343-b28)
# Java VM: OpenJDK 64-Bit Server VM (25.152-b28 mixed mode bsd-amd64 compressed oops)
# Problematic frame:
# V  [libjvm.dylib+0x406574]
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
#

---------------  T H R E A D  ---------------

Current thread (0x00007ffd20821800):  JavaThread "C2 CompilerThread2" daemon [_thread_in_native, id=42499, stack(0x000070000522d000,0x000070000532d000)]

siginfo: si_signo: 11 (SIGSEGV), si_code: 1 (SEGV_MAPERR), si_addr: 0x000077fd22e98478

Registers:
RAX=0x00007ffd2932bcf0, RBX=0x00007ffd2932bcf0, RCX=0x000077fd22e98460, RDX=0x00007ffd21070c20
RSP=0x00007000053298c0, RBP=0x0000700005329930, RSI=0x00007ffd2932bcf0, RDI=0x000070000532a6d0
R8 =0x0000000000000000, R9 =0x0000000000000001, R10=0x0000000000000000, R11=0xffffffffff589ff0
R12=0x00007ffd223205b0, R13=0x00007ffd23dd12c8, R14=0x0000000000000000, R15=0x00007ffd2932bcf0
RIP=0x000000011080b574, EFLAGS=0x0000000000010246, ERR=0x0000000000000004
  TRAPNO=0x000000000000000e

Top of Stack: (sp=0x00007000053298c0)
0x00007000053298c0:   00007ffd2932bf48 00007ffd2932bcf0
0x00007000053298d0:   0000700005329930 000000011055a376
0x00007000053298e0:   0000000000000001 00007ffd2932bcf0
0x00007000053298f0:   0000700005329930 000070000532a6d0
0x0000700005329900:   000070000532a6d0 00007ffd2932bcf0
0x0000700005329910:   00007ffd223205b0 00007ffd23dd12c8
0x0000700005329920:   0000000000000000 00007ffd2932bcf0

I could not find what the reason is. Can somebody help me?

sam

5 answers

1

Interij runs on OpenJDK by default, and the reason for your problem may be that the version of OpenJDK used by interij has a conflict with the Oracle JDK. My idea is to change the interij default JDK to Oracle JDK. And I find the steps on Interij's official website.

  • Firstly, start your interij and ignore the Java crash.
  • Secondly, press Ctrl + Shift + A and type Switch Boot JDK.
  • Thirdly, double click the "Switch Boot JDK" item bar and choose your Oracle JDK installation directory.
  • Finally, restart your interij.

search bar

Switch Boot JDK

0

Please try removing -Xmx750m from JVM Arguments. I am guessing it might be due to heap size.

Note: By default, -Xmx takes 25% of available memory.

0

Did you try ulimit -a and check core file size in result? If core file size is 0 mean that you can't create core dumps.

then you can try ulimit -c unlimited to set that is unlimited

You can see more information about ulimit in this link Setting limits with ulimit

0

Reinstall JDK, and then reinstall Intellij. Maybe it is a instalation issue.

-1

It could be a memory issue if it sometimes crashes. Have you tried to adjust the memory options in idea64.vmoptions? https://intellij-support.jetbrains.com/hc/en-us/articles/206544869