Hanging JDBC query with Impala

Refresh

April 2019

Views

167 time

1

I am having a weird issue. I am building an automated testing A/B tool in order compare Impala to other sources. I have 100 queries I am trying to run, that run fine through other sources and within Impala through Hue. I try to run certain queries into Impala from Java and it hangs. I run same text in Hue and it works. I figure it’s a non-printable character and remove all of them before issuing the query. Still hangs. No exception bubbles up, sits there for an hour. No evidence of query within Cloudera Manager I am at a loss. This is for SQL A/B testing. I have Jethro running consistently in 1-2 second range on almost all queries we tested. I can't document comparison to Impala across 100 queries until I get over this hump. I tried setting Simba JDBC logging through connection string and that did nothing.

Any thoughts on next steps for debugging the issue? Believe it or not, I am locked down corporate machine and do not have HEX or ASCII char view of my query.

0 answers