Gradle sync failed: Could not connect to server

Refresh

April 2019

Views

1.6k time

1

In my android studio 3.0 i am continuously getting this error -

Cannot start internal HTTP server. Git integration, JavaScript debugger and LiveEdit may operate with errors. Please check your firewall settings and restart Android Studio.

after this my gradle sync also failed stating the error -

Gradle sync failed: Could not connect to server [a3ea2c7d-cc16-4af2-82a9-037277903c02 port:49555, addresses:[/127.0.0.1]]. Tried addresses: [/127.0.0.1].

One thing to note down that this gradle sync failed when it(gradle) is connecting to gradle daemon. i have tried all the options from stack overflow like netsh winsock reset etc. But nothing work for me. Also to mention i do not use embedded JDK in AS. I have provided it my downloaded jdk8. How to solve this problem. Thanks in advance.

1 answers

0
  1. Make sure your machine is connected to the internet.
  2. Check the link here: Configure Android Studio - Proxy
  3. I personally recommend that you try disabling the proxy if it is enabled.
  4. Go to Windows Firewall -> Inbound & Outbound Rules -> add java.exe from JDK path & studio.exe from Android Studio directory.