DYLD: Incompatible library version for cmake

Refresh

November 2018

Views

497 time

0

OS: Mac 10.11.1

When I tried to "cmake", I got the following error message dyld: Library not loaded: /opt/local/lib/libexpat.1.dylib Referenced from: /opt/local/bin/cmake Reason: Incompatible library version: cmake requires version 8.0.0 or later, but libexpat.1.dylib provides version 7.0.0 Trace/BPT trap: 5

I also installed a fresh copy of CMake application, by running "/Applications/CMake.app/Contents/bin/ccmake", I got the following error message dyld: Library not loaded: /opt/local/lib/liblzma.5.dylib Referenced from: /opt/local/lib/libTIFF.dylib Reason: Incompatible library version: libTIFF.dylib requires version 8.0.0 or later, but liblzma.5.dylib provides version 6.0.0 Trace/BPT trap: 5

Any help would be highly appreciated! Thanks!

TTZ

1 answers

0

Он теперь работает после того, как я закомментировал dyld линии в bash_profile ...

TTZ