Chrome Netbeans Plugin only shows blank page

Refresh

March 2019

Views

732 time

1

I'm learning AngularJS at the moment and thought I would install netbeans as it supports debugging in chrome via a plugin. Or claims to at least...

I have followed the user guides and tutorials that I've found and always seem to falter at the same point:

  1. Install Netbeans
  2. Install chrome plugin
  3. Create a simple sample project
  4. Set the default web browser to Chrome with Plugin
  5. Click run

At this point I always see a blank page loaded in Chrome. I suspect that this is a bug as all of the resources online seem sure that I should be able to see the default index.hmtl page in my browser...

I'm running on a MAC:

MAC Info

And my plugin version is:

Plugin Info

My Netbeans version:

Netbeans Info

My Default Browser in Netbeans:

enter image description here

Does anyone know of any issues with running this configuration? No matter what I do I just see a blank page with a mangled URL like so when I hit run:

http://file:///private/var/folders/4l/3gq9477n6_952q1ztvz5ngdckcdyx4/T/blank2587611836421039861.html

When I open this file in VI I see one line in it:

<html :netbeans_temporary="true"></html>

1 answers

2

Это, казалось, работал в качестве обходного для меня:

  1. Открыть конфигурацию проекта и изменить браузер из Chrome с разъемом Netbeans для Chrome
  2. Запустите проект (правильная страница должна выйти в Chrome)
  3. Нажмите на Netbeans разъем в верхнем правом углу окна Chrome
  4. Выберите «Отладку в Netbeans» (Вы должны получить желтое информационное уведомление через верхнюю часть окна)
  5. Вернуться к Netbeans и нажмите на «основной отладки проекта» кнопку.

Моя конфигурация ОС / х High Sierra, Netbeans 8,2